Issues with connecting quadlock to ISO (new car stereo system)

Mitsubishi i-MiEV Forum

Help Support Mitsubishi i-MiEV Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Feb 3, 2022
Hi. I bought a new car stereo - Fence Audio, which has standard ISO contacts.
I also had to buy an ISO adapter to the quadlock. However - I've faced some difficulities.

The stereo illuminates for 3 seconds when i turn on the ignition, however - after those seconds it turns off again.
Eject button seems to be the only responsive button.

I've tried to diagnose it, and I think it is the original three power wires that has some kind of faults, so I bought a multimeter in order to test them.

Above are the results. None of the wires has voltage when ignition is off. The green wire did not give a voltage with the black one - but when using the metal, it gave 14.4 volts

Red gave 9.5 volts when measured with the black wire

The cigarette port gave 14.5 volts.

To be honest, I do not know what red, green and black represent.
I think red is positive ignition, green negative ignition and black is ground. However - I am very confused.

Moving on, I think that the red 9.5volt should not be so low. My plan is to maybe tap into the fuze-box (with a double fuze cable) and route it to the red. And green (if its right for it to be constant) wire it with something in the fuzebox that is constant. That being said, I do not know which one is positive and which is negative.

I have many pictures and videos that can show the problem, and I really want to make it work as soon as possible. So any help would be much appericiated!


Above is a better look of the adapter
Lastly, a better look at the harness

The harness has 1 extra black wire as illustrated - the one at the top
Hi I ran into the same issue, but for me I can't even measure the 14V between the green and the metal. That is also 0. Did you manage to figure out the solution? :) I know it is an old post, but I'm curious. Thanks.