Help with identifying P1A15 error source

Mitsubishi i-MiEV Forum

Help Support Mitsubishi i-MiEV Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


New member
Feb 11, 2023

I have an 2012 C-zero which is throwing the infamous P1A15 error.
I have read most of the posts regarding this problem, and done some initial tests already. I now seek guidance on what to try next.

To start from the start:
I am about to sell the vehicle. I have upgraded to a much newer 2014 Leaf. Which has the app that I so dearly have been missing on cold Norwegian mornings.
This thursday I took the car to a machine carwash. After the was i parked and took some exterior pictures (without turning the key off after the wash incidently).
When I got home I parked the car and connected the charger. Yellow car with exclamation mark. Tried 3 different chargers. Yes, I too have 3 different chargers. Nothing works. I then try to turn the car on. And it is no longer entering READY mode.

And so the troubleshooting begins.

During the last couple of years the cars 12V battery has been emptied about 3 times from the car not being used. Thinking it was a problem with the 12V, I charged the battery. Deleted error code. Still the yellow car.

I am able to delete the code with my OBD2 dongle and car scanner. The relays stays silent when I do not. And they make the clickity clacks after I delete the error.

I borrowed the 12V from another vehicle. (Connected with jumper cables, as the battery was twice the size, if that should matter. The battery was disconnected from the other car).
Same situation.

I am now reading the capacitor voltage when I try the starter after deleting the code. 324 V. The main battery holds 336 V. The magical 12V difference. The capacitor voltage quickly rises to 324 V. Plateauing there for some ms, before the error comes and it drops to 2 V again.

I have since tried a handful of times, and succesfully made the car go into READY 3 times. Each time it has worked I have deleted the code the day before. The 12 V battery has been fully charged over night. And I start it quickly. Without connecting the OBD2 after turning the key halfway etc.
The last time I read the capacitor voltage. Still exactly 12 V difference. It might be 11.9 V now, and 12.1 V later. I do not know.

When the car is in READY, I am able to drive. The heater works, and the water pump runs.
When I press "A/C" there is no power being drawn by the A/C compressor. 0 RPM and 0 W. Pressure is steady at 0.25-0.27 MPa (I believe it was MPa). I remember reading somwhere that water in the A/C compressor could make problems.
When I did this today, the environmental temperature was below 0°C. And the cabin was around 4°C. So it might be normal for the A/C compressor not to run in those conditions. Is that so?

I have a feeling the carwash is the problem. The car has not been washed in a machine for the last 3-4 years I believe. And when I suddenly do, it goes down.

The trip I made when I washed and took pictures is also notable. There were a lot of condensation on the inside of the window. I ran the heater on max (with A/C if that matters) for about 40 minutes. 20 of them after the carwash. I am unsure if the A/C is doing anything when the wheel is turned to heating. But for this specific ride, I felt as though it made a difference when I turned it on. But I am open for that being a placebo.

I have tried opening the chargeports so that water can escape. I do not see visible water inside either port.

When I connect the 230 V AC charging there is only 1 relay click before the yellow car is visible (after deleting the error code).

The 12V dips a bit more than what I would expect. But it can hold 12.0 V or more when the lights are engaged. I do not have very spesific data on this. But I do not think the 12 V battery is the problem.

Any help with thinking is appreciated!
Well you have quite a bit to unpack here, but i'll throw in my 2c.

First need to rule out the 12V starter battery. An old, weak or worn out battery won't charge back up especially if it has been let run down and the plates have sulfated.

With a good strong battery installed, clear the DTC codes, then try to charge the car; hopefully that will work okay and the DCDC Converter will be putting out 14.4 to charge the starter battery.

Then try to start the car to READY; if it fails then look up the DTCs. If it has the P1A15, then the hybrid board is likely defective and would need to be replaced with a good one or with an AD202 isolation amplifier.

Many folks have tried adding resistors and even replacing nearly every component on the board except the transformers. It is quite a puzzle.
Thank you!

I tried the easier route first. I tried disconnecting the A/C. Still no change. The car starts once if I leave it be for a day. If I try again, it fails.
Everytime I handle those 400V connectors I feel like I am dipping a toe in the afterlife.. Even with the service disconnect out.

I have tried 4 different 12v batteries now. One which normally sits in my fully functioning Leaf. The other batteries have only been connected with jumper cables. The OBD reads more than 12v, even when I try to start without it going to READY.

(Wouldn't the 12v battery voltage drop a lot under 12v if it was bad? From my understanding of batteries, I believe the voltage will drop if the battery is not able to deliver enough current.)

When the car goes into READY, the 12V reads 14.4V, so that is good.

There is still always the 12V difference between capacitor and drive battery.

Have I understood it correctly that the resistor option is only making the circuit meassure a bit different? And that something else will eventually degrade so that it will not work? And that the AD202 option will replace something, so that it will function "forever"?

Methaforically, the resistor is treating the symptom, and the AD202 is fixing the core issue, correct?
Yes the resistor is a bandaid fix to fake out the system by adding gain on the front end to hopefully offset the gain loss due to degradation on the hybrid. Gencis said that he did this and it is still working okay for him, so in some cases this might work.

We don't have any good data about what component degrades on the hybrid and causes this mess. i spent alot of time working with member boo,,, replacing nearly every component on a defective board (except for the transformers) with no luck. i sure would like to find out what degrades on the hybrid board.

The AD202 is a replacement isolation amplifier that seems to work for those who have tried it.