No READY. P1A15 error. Condenser charge timeout.

Mitsubishi i-MiEV Forum

Help Support Mitsubishi i-MiEV Forum:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.
Thank you kiev for the detailed information. That was what I needed. I'll try to remove the MCU and check if there are some faulty elements in the circuit. The car cannot start because the ECU can't measure the voltage of the capacitor.

I'll try to take some measurements and see if I can find the culprit that messes with the measurement. It will be hard to measure and debug the circuit. I hope that I don't blow anything and fry the inverter board. Probably I should look for someone with more experience in these kind of things.

If something wrong happens I'll have to go by Lic's steps or to find another way to put a custom MCU and try to make it work.

I hope Lic manages to fix his problem with the new MCU and get back on the road.
Hey guys,

The problem is fixed and the car is back on the road. I found a guy that has experience with electric vehicles. He managed to trace the faulty circuit.

The problem was the chip that measures the voltage of the capacitor - the small one bellow the two small transformers.

I'm not sure what are its specifications. I don't have clear pictures of it to look for it in google.

The important thing here is that it measures the voltage but it gives wrong data to the ECU and at first look it works as it should.

I'm really happy that the car runs fine and hope there will be no problems soon.

I hope that this can be of any use to you guys
Thank you kirq4e for the follow up with your solution. What month was your car built according to the label on the door jam. Or what is the VIN, to search for recall notices.

That chip is an op amp made by Analog Devices, AD8677. It is used on the little hybrid board soldered to the main board.

The hybrid is an isolation amplifier board made by Nihon Pulse Industry, ISA215, used to measure the high voltage of the pack and isolate it from the low level logic control circuits.

My 2012 had these same symptoms with this DTC code but i wasn't as deep into the circuits as now. My car was included in a limited recall to replace the MCU and the problem was solved.

i think the recall indicated an issue with insulation or something that was leaking current causing the DTC, but now my guess is that a failure such as this on the ISA was the cause of the limited recall.

How did they know to limit the recall to just a few cars within a month's build date? --Because there is a lot code number in white ink stamped over the coating on the ISA board. So very easy to trace which cars had the bad batch.
Hi guys,

I'm really happy with the car, but the joy was short. The problem appeared again. I drove the car home, charged it. Showed me 111 km estimated range which surprised me. Yesterday I started my daily routine but at the first stop the check engine light lighted again and couldn't go into Ready. Now the car is back in the service centre and the guys will try to find the real fault that is causing the issue.

I'm not sure which month the car was built but the first registration is 01.2011. The VIN is VF71NZKZZBU900242. I couldn't find if it is in the recall notice. The original Citroen service centre told me only for a recall about the passenger airbag which already waits for me to take the car.

If the problem cannot be fixed the only thing left is to get a second hand MCU and try to move the VIN encoded chips.
Did yall check the other components in the schematic, such as the photocoupler PC7 and the FET2? What about the value of the resistors in the voltage divider, and all the little capacitors?

If the FET2 were slightly turned ON by leakage thru the PC7, then it could pull the voltage down by 8-10 volts with just a small current (~20mA) thru the large silver bleed resistor.

One troubleshooting test might be to open the circuit to the FET by disconnecting from the board the CN5 connector to the bleed resistor--now there is no leakage path in that leg. It will cause a slower bleed down of the 800uF cap and that might throw a different code, but at least it might allow it to go to READY if the FET leg is the source of the leakage.

Another idea is to replace the entire ISA215N hybrid board. The op amp is one component on that board, but there are several more, any of which could disrupt the function of the isolation amplifier. But i don't think it could pull down the capacitor voltage such as current thru the bleed resistor would.
Hi guys,

I'm happy to share with you that the problem is fixed. The guy changed almost everything on the schema - the photocoupler, resistors and FET2. The problem appeared when the car gets slightly warmer after a few kilometers of driving. It appears that some of the components were changing their characteristics when the temperature gets a little higher. He said that he measured all of the resistors and they seemed to be OK but he decided to replace them.

So now the car is working fine. Managed to drive 35 km and 30 on the GOM. Today after I charged it the GOM displays 123 km of range which is more than enought for my daily driving. Probably the car will be charged once 2-3 days.

Thank you very much kiev for your help. Lic I hope you can fix your problem sooner.
Thanks for sharing your repair experience.

It looks to me that there are 2 legs in that circuit, either of which could cause this problem.

One is a real voltage drop in the path involving the photocoupler, FET2 and the bleed resistor.

The other is an error (thermally-induced) in the voltage measurement leg feeding into the ISA215 hybrid board used to sense the HV.

Since the issue seems to be thermally induced and is not a permanent failure, and you thought replacing the op amp on the hybrid board fixed it (in the measurement leg), then either the series resistor string or the little chip capacitors would be good suspects. i hope he replaced the caps along with the resistors.

Those little ceramic chip capacitors can get stressed and crack at the solder joint, then get leaky and recover in thermal cycling. The little chip resistors could change value under thermal cycling, but it is a less common failure in my experience.

They put 3 caps in parallel, likely as a redundancy against failure, but there should have also been a series string to be effective. Tesla does this on their battery cell voltage measuring circuit.
Hi guys. I see kirq4e fixed his car. it is very good. I was not able look my car yet. My mechanic sold his shop and can't help me any more. So It is look like I need to repair my hybrid board or I need to find out if I can just change eeprom chip from my inverter board. My question is - is it difficult to remove mcu from a car to get access to inverter board? Can I do it by myself in garage? I am sure I can do it in shop by myself, but I don't have access in shop anymore.
i think you should be able to do it in your garage fairly easily. The 2 coolant lines will likely be the messy part, then there are two small control connectors, a small connector on the temperature sensor, one big orange connector across the front from the DC/DC, and 5 large wires for HV--two from the pack and three to the motor, underneath the access cover (need a T30 Torqs screwdriver/bit). Two bolts thru flanges toward the front and one flange at the rear, then it comes out. flip it over on your work bench and remove the cover bolts--you're in like flint, and Bob's your uncle!
Thanks kiev. I am doing repair so long time because I am working far away from home. So I decided to bring car closer to me to be able to finish repair. I bought hitch bar and I will remove front bumper to somehow connect hitch bar to car. I will tow car in ready and in neutral mode. I hope everything will be fine and I finally will get car working.
ISA215N board by Nihon Pulse in Japan,
[edit 9/22/20] These links appear dead or blocked.



I have the same code and have had a local Circuit Board repair guy check out the MCU board with the info above, he says that everything is fine on my board. I have also been through the full Mitsubishi Diagnostic process, I have had my pack out and measured resistances and insulation resistance on the contactors. My diagnostics reads pack voltage at 350v and if I clear the codes and try to start I can watch the capacitor/condenser voltage match battery voltage for 1 second then it drops away. I can see that (-) contactor actuating but not the (+).

Are there any other known causes for this fault code like the DC to DC problem or does that fire a different trouble code.

Or has my circuit board guy missed something?

The voltage on the condenser is 2v when it drains back off does this imply anything
Did you check all the components in the schematic on page 2?

The precharge resistor circuit will charge up the MCU capacitor voltage toward Pack Voltage in the first second, then the Positive contactor is supposed to come ON and hold that voltage as the precharge is turned OFF.

It sounds as if you are seeing the precharge effect, but the (+) contactor is not energized for some reason. There is a bleeder resistor in the MCU that drains the big capacitor if it is not being charged or held up. Also there is a fast bleed resistor thru a FET in the bottom plenum shown in the schematic on page 2. If the FET is stuck ON for some reason, then the fast bleed will prevent the Cap voltage from reaching the proper level and throw this code.

i think there is a data item in the MUT to read if the contactors are open or closed. How are you detecting that the (+) contactor is not coming ON?

Large capacitors will often appear to self-charge and hold a very low voltage after discharge, so 2V is nothing to worry about. It will charge up from the meter leads when you try to measure it.
All my live measurements are taken through my scan obd software. It tells me if the contactors are open or closed in real time, so I can watch the voltage and contactors as I try to start the car.

The board guy checked everything on the board that can be check without power or de soldering.

All the resistors checked out fine, but I don't know if they are being charged or not.
So if the main (+) is not commanded to come ON, then it may be an issue inside the EV-ECU under the rear seat that sends the coil drive signals to the Pack.

The (+) drive is on pin 107 of connector C-111. It should have 12V on that line with key at ON, and drop to 1V or less after the key goes to START. pin 106 is for the (-) contactor, and has the same key ON and START voltage response, so if it is coming ON, then monitor that and compare with the response of the (+).

Do you know if the car might have had a sudden shutdown event or power hiccup while driving? The main (+) contacts may be frosted over and not conducting if the coil drive was removed while current was flowing thru the contacts--this would cause a large DC arc inside the contactor and damage the precious metal surfaces of the contacts. Possible cause would be weak or failed 12V aux battery.
Contactors are fine, perfect resistance so I am happy that they are ok.

I came across a 2nd hand controller for a good price. so I have just fitted it. HV fault gone but vin miss match still stopping it go into ready. My computer can't sort it so I need to see what my options are. I remember earlier in this thread someone else doing the same, so I'll have a read and a think.
i wish we had a way to re-program the VIN, but there is an eeprom chip in the bottom plenum of the MCU that supposedly contains the VIN. It was swapped to get the MCU working.

i have used an arduino UNO board to make an eeprom reader/writer for the CMU boards, but haven't done it for this chip.
Based on the findings from this thread I did some further tests today on my MCU with the same symptoms (P1A15 when car is "hot"):
I mounted the MCU without the lower cover, I put the car in Ready and noted the Vbatt and Vcapacitor from Scantool (same as MUT-3 but for Peugeot)
Batt: 354.8V
Capacitor: 346V

I switched off and disconnected cn5, I was able to put ready:
Batt: 354.8V
Capacitor: 346V
So not leak on the fast bleeder resistor through the FET...

Then still in ready with CN5 disconnected, I applied hot air on the circuit board using a 1000/2000W fan heater.
I rapidly saw the Vcapacitor dropping from 346V to 340V by 2v increments... It took only 1 minute

More tests to come....