danieldjan
Posts: 2
Joined: Tue Oct 06, 2020 3:11 am

Re: Troubleshooting and repair for On-board Charger (OBC), DC-DC Converter

Fri Oct 09, 2020 4:31 am

kiev wrote:Howdy Daniel,

Sorry to hear that you are having a problem, but maybe it can be repaired. We need to know more about how the car is responding. You said that CHAdeMO charging works, but that EVSE charging fails.

Does the car go to READY in a normal manner and run and drive okay?

Does the 12V aux battery voltage get up to 14.4 when the car is in READY?

Did you check the 20A fuse underneath the small cover plate of the Motor Control Unit aka inverter? Usually that has blown if there has been a failure in the OBC, and the 12V aux will not be charging while in READY.

Based upon the crackling sound you describe coming from under the car in the pack, i would suspect that one or more of the main contactors has been damaged by intermittent holding when current was flowing. This could damage the precious metal surfaces of the contact points. The other idea is that the pre-charge resistor has been overheated and gone open circuit. But if any of these has occurred then the car will not go to READY.

take care,
kenny


Hello Kenny,
On very beginning, many thanks for your wish to help. I realize now that I am not alone. Regarding your suggestions:

Car go to READY in a normal manner and run and drive. All is totally normal, and I am driving it like this more than 20 days.

The 12V aux battery voltage get up to 14.3-14.4 when the car is in READY, battery is 3 months old, so almost new. This was first issue that I did check (I follow all instructions on first page of this thread).

I did not check the 20A fuse of MCU, since the car 12V is charging, and car does not have any error.

Both suggestion for the main contactors and pre-charge resistor I did not take under probable cause since the car was going in READY and drives normally.

Even I am Biotechnology engineer and not specialist for EV, I first did read all post in this thread, to try to make repair without asking for help. The thing which is making me trouble is that there is no singe code with error in system, car is running normally and fast charging without a problem, so I am like a blind man having no idea where to look for possible problem. The only place I did not look for a problem is in metal box on bottom side of car, in centre, where the cable from inventor is going in since I was worry not to make a problem if I can not seal it properly after opening. Since the crackling is coming (I guess) from this part, my question is if there is rationale to open and look for a possible problem down there?

Also, the car acts when I start charging like the battery is 100% full. Maybe a stupid question, but, how the system controls and stops charging of battery? Can I look there for possible cause of problem?

Many thanks in advance for reply, any suggestion will be valuable.
Daniel

kiev
Posts: 1257
Joined: Sun May 03, 2015 7:15 am
Location: The Heart o' Dixie
Contact: Website

Re: Troubleshooting and repair for On-board Charger (OBC), DC-DC Converter

Fri Oct 09, 2020 6:14 am

i'm not understanding which metal box you mean--is it the main battery pack or the OBC? Can you point to a picture of the item from post #1 of this thread?

When does the crackling sound occur--during EVVSE charging attempts or all the time during START or READY?

i would recommend to remove the top cover of the OBC and take a look for damaged capacitors on the AC input path, either on the top board or bottom board doghouse areas.

For example look for something like this on the black rectangular cap in the potted area,
Good
Image
Bad
Image
Image
Image
Image
Last edited by kiev on Fri Oct 09, 2020 6:46 pm, edited 11 times in total.
kiev = kenny's innovative electric vehicle

coulomb
Posts: 226
Joined: Sun Jun 10, 2018 8:32 pm
Location: Brisbane, Australia

Re: Troubleshooting and repair for On-board Charger (OBC), DC-DC Converter

Fri Oct 09, 2020 6:24 am

Some capacitors can make faint crackling noises. The 2.2 μF 275 VAC gray film capacitors in Elcon charrgers used to do this. Replacing them with new blue versions (the color may correlate with the manufacturer) solves that problem.

Of course, it could also be something breaking down due to moisture or other causes.

kiev
Posts: 1257
Joined: Sun May 03, 2015 7:15 am
Location: The Heart o' Dixie
Contact: Website

Page One Edits?

Fri Oct 09, 2020 6:44 pm

i've been wanting to clean up the first page to make it more useful to find stuff without having to read thru this whole mess.

today i read thru this thread and moved copies of lots of pictures from the body to a Pitcures section in the first post, but now it is a huge post.

i had somewhat of an index in post #2, but it needs cleaning up and better organization.

Post #3 i had thought to put all the schematic drawings and replace all the handwritten sketches with nice line drawings (work in progress).

i have a spot in post #5 that could be used as the picture displaying spot and move them out of #1, or move nearly all of #1 to #5, and rewrite #1 more as a summary with the benefit of all that we have seen, heard and learned from so many contributors over the past few years.

So i'm open to ideas, suggestions and advice on what might help folks having problems across the wide spectrum of people's knowledge and skills with respect to electricity.

let the good times roll,
kiev = kenny's innovative electric vehicle

Return to “Batteries and Battery Management”