coulomb
Posts: 198
Joined: Sun Jun 10, 2018 8:32 pm
Location: Brisbane, Australia

Re: not charging my iON, cell or CMU or BMU problems

Sat May 23, 2020 10:44 pm

martinwinlow wrote:I appear today to have confirmed that the MUT3 can renumber CMU BMS PCBs

I actually thought that they would renumber themselves, using a daisy chained pair of wires between each CMU.

Are you sure you needed the MUT3 for this? Perhaps the MUT3 is needed to "kick things off", and the CMUs then renumber themselves based on their position in the daisy chain.

DBMandrake
Posts: 282
Joined: Mon Mar 20, 2017 4:57 am
Location: Scotland

Re: not charging my iON, cell or CMU or BMU problems

Sun May 24, 2020 12:59 am

coulomb wrote:
martinwinlow wrote:I appear today to have confirmed that the MUT3 can renumber CMU BMS PCBs

I actually thought that they would renumber themselves, using a daisy chained pair of wires between each CMU.

Are you sure you needed the MUT3 for this? Perhaps the MUT3 is needed to "kick things off", and the CMUs then renumber themselves based on their position in the daisy chain.

That's apparently exactly how it works, however the diagnostic tool is required to "kick it off" and cause the self renumbering to take place, as prior to doing that it was setting a fault code for the CMU and the battery gauge was empty. (Due to no cell voltages from a block of cells)
- Simon

EV: 2011 Peugeot Ion
ICE: 1997 Citroen Xantia V6

martinwinlow
Posts: 66
Joined: Sat Sep 01, 2012 3:02 am

Re: not charging my iON, cell or CMU or BMU problems

Tue May 26, 2020 12:15 am

No 'kicking off'; there's a specific MUT3 app routine to do it (detailed on the SPeakEV thread, https://www.speakev.com/threads/i-miev-with-failing-battery-another-cmu-ltc-chip-failure.144620/page-3#post-2829628).

Unfortunately, it does not appear to have helped 100% in my case as it appears the version of CMU PCB that I got is not entirely compatible with my very early i-MiEV (last 5 of the VIN is 00136 and V5 shows first registered 20Nov2009).

However, the car goes to 'Ready' and the wheels go around and around, albeit it is still on the car lift. It charges, too (from AC), but I have not had a chance to see if it is at the full 13A, let alone via DC (no facilities to do that here on the island anyway).

So, my next plan is to try to obtain a pair of the same version of CMU PCBs and try them in the car.

Anyone know where I could try?

kiev
Posts: 1146
Joined: Sun May 03, 2015 7:15 am
Location: The Heart o' Dixie
Contact: Website

Re: not charging my iON, cell or CMU or BMU problems

Thu May 28, 2020 10:14 am

It wasn't clear to me that there was a defective LTC chip, maybe so, but there were 2 very low cells, #38 and #42.

So after swapping out a CMU05 board, the low cell #38 is not reading low anymore? Was the cell voltage actually measured with a voltmeter to verify it's actual reading before and after the CMU?

As long as the pack is open, maybe some other tests might be to put the old CMU back in to see if the problem returns. And move cell #38 to another location. Change some things around and see what the tools show, etc.

i would definitely want to put a meter on CMU06 cells (cell #42) to get measurements.
kiev = kenny's innovative electric vehicle

DBMandrake
Posts: 282
Joined: Mon Mar 20, 2017 4:57 am
Location: Scotland

Re: not charging my iON, cell or CMU or BMU problems

Mon Jun 29, 2020 12:36 pm

Martin has probably forgotten to post back here but on SpeakEV he has reported the problem as solved.

There was an interesting wrinkle to the issue though - his car is so old that it has pre-production or very very early production CMU boards which are coloured Red instead of the normal Green and have an early revision number than nobody has ever seen before, and also a partially incompatible firmware!!

When he tried to fit a regular green coloured second hand replacement CMU, the re-numbering process worked, however there were other fault codes still set due to (we believe) incompatible firmware versions between CMU and BMU.

So in the end he had to have a new LTC chip fitted to the original red board, this has fixed his problem and the car is back on the road charging and driving without fault codes.
- Simon

EV: 2011 Peugeot Ion
ICE: 1997 Citroen Xantia V6

Sandrosan
Posts: 16
Joined: Tue Sep 24, 2019 2:43 am
Location: Milan, Italy

Re: not charging my iON, cell or CMU or BMU problems

Tue Jun 30, 2020 10:35 am

Thanks Simon! Very good to know he has solved with a new LTC chip.

DBMandrake
Posts: 282
Joined: Mon Mar 20, 2017 4:57 am
Location: Scotland

Re: not charging my iON, cell or CMU or BMU problems

Tue Jun 30, 2020 12:08 pm

Sandrosan wrote:Thanks Simon! Very good to know he has solved with a new LTC chip.

As long as it's done very carefully by someone with the right solder rework equipment and skills, it does seem that the LTC chip replacement is the most likely repair method to be successful, (side stepping all possible numbering and firmware issues) and the good news is the chip itself is still available to buy new at a very reasonable price, even if second hand CMU boards weren't available.
- Simon

EV: 2011 Peugeot Ion
ICE: 1997 Citroen Xantia V6

Return to “Batteries and Battery Management”