DougC
Posts: 34
Joined: Mon Mar 23, 2015 11:26 am
Location: Between Flint and Detroit, Michigan

Shifter starting to have problems

Thu Aug 15, 2019 10:22 am

I've seen others have had this problem, but my shifter is starting cause problems.

It no longer shifts as smooth as it used to, it won't always display the correct position. I have to shift to B twice to get it to take. Not always going into P when it should, which causes the charger not to start, also parking pawl sometimes doesn't engage.

I've done a search here and saw some threads on the topic but still have some questions.

-Has anyone done a DIY fix or swap out of the shifter switch piece?
-I would like to know if this is a task that the home mechanic should try.
-What does the part look like? Anyone have pictures?

I've just downloaded the tech manual from the forum and will take a look at that, once I reboot this computer.

Doug

Gary12345
Posts: 36
Joined: Tue Feb 12, 2019 4:15 am
Location: Essex, UK

Re: Shifter starting to have problems

Fri Aug 16, 2019 5:56 am

From what i've read, issues like this were resolved by greasing the linkage at the motor/gearbox end. There are 2 sensors and if they disagree it causes you issues.

Thanks.

DougC
Posts: 34
Joined: Mon Mar 23, 2015 11:26 am
Location: Between Flint and Detroit, Michigan

Re: Shifter starting to have problems

Fri Aug 16, 2019 10:03 am

Thanks.

I've never looked in that area. I'll have to open it up and see what can be done.

Return to “General Technical Discussions”