1pk
Posts: 47
Joined: Thu Jul 10, 2014 7:34 am
Location: Chemainus, BC

And now my I will not charge!!

Thu Jun 28, 2018 10:08 pm

I plugged in at home today after work and it clicked and whirred, but then my evse clicked off and it would not charge. After several attempts I gave up and tried my portable unit with the same result. Now I sit at the closest DCFC getting some electrons for tomorrow’s commute and I am thankful this is working!

It starts, and drives, there are no warning lights on the dash. I could use a little guidance on what to check. I am not an electronics guy but I follow directions well so I hope I can sort out the problem with a little help from you smart folks on this forum.

My car has 132k km and the 12v is new as of last October. I tried to check the voltage but my voltmeter seems to be hooped. I will borrow one tomorrow and test to it.

Last weekend I noted some unusual charging behavior. I needed a small top up to get home so I stopped at an L2. In 18 min the car charged 500wh. I tried another charger (flo is the provider) and that one was the same. Off to the next one and that worked for 5 minutes and shut off. That was enough to get me barely to a DCfC which worked fine.

That all happened on Sunday and everything has been fine until tonight.

Where do I start?

Thanks

Pete

1pk
Posts: 47
Joined: Thu Jul 10, 2014 7:34 am
Location: Chemainus, BC

Re: And now my I will not charge!!

Fri Jun 29, 2018 8:35 am

After my 40km commute the accessory battery is sitting at 13v

Voltage rises to 14.5v In ready mode

kiev
Posts: 664
Joined: Sun May 03, 2015 7:15 am
Location: The Heart o' Dixie
Contact: Website

Re: And now my I will not charge!!

Fri Jun 29, 2018 10:44 am

Your 12V Aux battery appears in great shape.

Since your car charges with DCQC level 3, and is intermittent with the level 1 or 2 EVSE, then it points to an issue with the path using the onboard charger. The pack is likely okay since it does charge properly with Chademo.

The biggest source of intermittent issues is dirty or corroded terminals in a connector.

Inspect the EVSE handle contacts and those on the car's charging port with a bright flashlight, then clean any dirt, debris or insect parts out of the sockets using a wooden toothpick, cotton swab and rubbing alcohol. If there is any blue or green colored deposits then use vinegar to clean those off.

Hopefully that will get it working again--let us know what you find in those sockets.
kiev = kenny's innovative electric vehicle

1pk
Posts: 47
Joined: Thu Jul 10, 2014 7:34 am
Location: Chemainus, BC

Re: And now my I will not charge!!

Fri Jun 29, 2018 4:26 pm

Ok, cleaned the charge port with q-tips.

This is what it looked like before I cleaned it.


https://imgur.com/a/LFkjiVO

Unfortunately there was no change in the charging behaviour.

I tested it on a public charger after work. This particular charger really wanted to work so it kept restarting.

Here’s What canion displayed during the attempt
https://imgur.com/a/Nrr6cts

I appreciate the help. What do you think?

Pete

jray3
Posts: 1501
Joined: Tue Dec 06, 2011 1:05 am
Location: Tacoma area, WA
Contact: Website

Re: And now my I will not charge!!

Fri Jun 29, 2018 5:46 pm

With a blown charger 20a output fuse, it’ll do the j1772 handshake and cycle the fan, then shut down. However, I think that fuse is shared with the DCDC input, so this chump is stumped. Some other charger failure?
2012 i-SE "MR BEAN" 87,000 miles
2012 i-ES traded at 21,648 miles
1983 Grumman Kurbwatt,170 kW, 32 kWh
1983 Mazda RX-7 EV 43 kW 10 kWh
1971 "Karmann Eclectric" EV 240 kW 19 kWh
1965 Karmann Ghia Cabriolet

1pk
Posts: 47
Joined: Thu Jul 10, 2014 7:34 am
Location: Chemainus, BC

Re: And now my I will not charge!!

Sat Jun 30, 2018 1:20 pm

I see the troubleshooting thread started. Looks like a lot of us are in need of help with this issue. I’m going to keep this thread going for my car. Hopefully it will help other folks who are at my level of knowledge.

I’ve dug into the rear compartment and taken some photos of the internals.

https://imgur.com/a/1E8FRTB

https://imgur.com/a/vrxwKz8

https://imgur.com/a/gifE8JM

https://imgur.com/a/x8nd5z3

https://imgur.com/a/s6A0eoE

So is the left box the inverter and the right one the MCU?

Which connections should I take apart to clean?

Are there any Spots that I can not touch for safety reasons?

Can I test that ceramic fuse?

kiev
Posts: 664
Joined: Sun May 03, 2015 7:15 am
Location: The Heart o' Dixie
Contact: Website

Re: And now my I will not charge!!

Sat Jun 30, 2018 3:15 pm

The charger/converter(dc-to-dc) box is on the left, and the Motor Control Unit (MCU, aka inverter) is on the right.

As long as the key has been OFF for 10-20 minutes there should not be any high voltage in either box. There is a bleed-off resistor that will drain the HV from the capacitor.

The fuse can be checked with a meter on either the resistance(Ohms) or continuity(beeper) setting. Since your 12V is reading 14.4 while in READY mode, this indicates that the fuse is good, else the dc-dc converter would not be receiving any HV thru that fuse to do its job.

i use a vacuum cleaner and brush to get up all the road dust and debris before opening any covers.

You could remove the screws following the number sequence arrows of the top board inside the charger, along with the AC input screws and CAN buss connector to lay that board over toward the right, then inspect the bottom board for any residue or debris from blown components.
kiev = kenny's innovative electric vehicle

1pk
Posts: 47
Joined: Thu Jul 10, 2014 7:34 am
Location: Chemainus, BC

Re: And now my I will not charge!!

Sat Jun 30, 2018 3:31 pm

Great , thank you! I will have a look at removing that board. I was very careful to not get debris into the electronics.

I see there Is no gasket on the lid just a sealant. What type of sealant is It? I’ll need to get some.

kiev
Posts: 664
Joined: Sun May 03, 2015 7:15 am
Location: The Heart o' Dixie
Contact: Website

Re: And now my I will not charge!!

Sat Jun 30, 2018 4:55 pm

The gray color of the sealant leads me to think it is an electronics grade RTV that doesn't off gas acid as it cures (non-corrosive). They are somewhat pricey but worth it for anything near electrical or electronic parts or boards. Less is better than more, a very thin bead is plenty.

But i haven't sealed mine back, just brushed off any dirt and bolted the cover back on--i'll probably be going back in there often and not worried about sealing until i'm done messing around in there...
kiev = kenny's innovative electric vehicle

1pk
Posts: 47
Joined: Thu Jul 10, 2014 7:34 am
Location: Chemainus, BC

Re: And now my I will not charge!!

Mon Jul 02, 2018 9:38 pm

So I opened up the inverter again and I couldn’t see anything obviously wrong.

Images of the circuit boards are below along with a closeup video scan. I wiggled all the spade connectors on the board but it didn’t change anything.

Bottom of the top board

https://imgur.com/a/w6eQjSW

Video of the bottom board looking for a problem.

https://imgur.com/a/IBSQkGt

Even though there are no warning lights, would it b helpful to take it in and check for error codes?

Return to “General / Main Owners Forum”