Page 1 of 1

Mitsu EVSE Ground Fault

Posted: Mon May 14, 2018 5:00 am
by bradleydavidgood777
I have a 2017 Mitsu EVSE which is a Yazaki model 9482A128. It worked fine for about a year and now about half the time I plug it in I get a ground fault.

I've plugged it in several locations other than my house where I know there are good grounds and I get the same behavior.

I figured I'd try to open it up and check the wiring to see if it looks solid. I removed all of the screws and carefully used a screwdriver to pry it open but it is not opening easy.

Has anyone had any experience opening one of these?

Or any other advice?

Thanks

Re: Mitsu EVSE Ground Fault

Posted: Mon May 14, 2018 6:48 pm
by kiev
Did you remove the screws located under the labels?

Re: Mitsu EVSE Ground Fault

Posted: Fri May 18, 2018 11:10 am
by bradleydavidgood777
kiev wrote:Did you remove the screws located under the labels?


I peeled the label off the bottom of the unit and there were no screws. I have the newer model.

Re: Mitsu EVSE Ground Fault

Posted: Sat May 19, 2018 5:21 am
by bradleydavidgood777

Re: Mitsu EVSE Ground Fault

Posted: Sat May 19, 2018 5:53 am
by kiev
i've never opened one of those, the Panasonic version has a potted control board and it is quite a pain to remove all the conformal coating without damage. i'm gonna guess that your board will be potted also.

The old version does 2 ground checks before allowing charging: one checks that the ground wire exists and provides a current flow path back for the Line; the other leaks a very low current thru the ground fault detection coil to prove that the GFCI circuit is functioning properly.

Image

Image