Page 67 of 69

Re: Canion

Posted: Sat Feb 17, 2018 8:32 am
by kiev
That is just the recycling code number for lithium ion batteries. For example high density polyethy plastic, HDPE, has a recyc code of "2".

Your pack is in great shape if you get that sort of range, easily an 88-cell 16kWh pack, especially since voltage is at 360V. The 80 cell packs are only 330 V

Not sure why the canion screens are not working for you. What is the frame rate while connected, seen in the lower right corner?

Re: Canion

Posted: Sun Feb 18, 2018 6:57 am
by Zelenec
Thanks, kiev.

Frame rate is as usual over 400 fps. All other panels are correct and refreshing instantly. Other 2 cars (C-Zero, Ion) same phone, same BT dongle, show also Batt Status and Temp.

Re: Canion

Posted: Sun Feb 18, 2018 9:05 am
by kiev
It could be that they have changed the PIDS for the 2015 car that are used for the CMU data, which is the cell monitoring units reporting of cell voltage and temperature.

Tesla did that on late model cars after the original PIDS were being discovered and reported on the TMC forum. That's when i lost interest in Tesla.

Re: Canion

Posted: Sun Feb 18, 2018 7:36 pm
by Zelenec
I was too superficial. I should look at the bottom of the sticker, where the capacity is marked with 16 kWh. Sorry.

Could be true about PIDs. I hope Martin and Xavier would maybe address this issue someday?...

Re: caniOn: Sponsor search program

Posted: Mon Mar 12, 2018 1:26 pm
by TobyGadd
Zelenec wrote:If I may... I wish you could address changes made with I-Miev MY 2015 and later causing Canion unable to show batt status and batt temp panels, which are the most important for any user. I have one I-Miev MY 2015 and a new I-Miev at home right now, so if I could help somehow, I'd try my best.

Will caniOn work with a USA 2016 i-MiEV?

Re: caniOn: Sponsor search program

Posted: Fri Mar 30, 2018 9:50 am
by TobyGadd
I'm finally driving my 2016 iMiev! (USA)

In an effort to learn as much about it as possible, and to keep it happy and healthy, I installed CaniOn. I would love to check battery status, but this doesn't seem possible. It is true that the 2016 year isn't supported, or am I just missing something.


Re: Canion

Posted: Tue Apr 17, 2018 4:31 am
by DBMandrake
At long last I was able to start using Canion yesterday using an OBDLink LX. Many thanks to Martin and Xavier for such a great program. :D

I have a few questions about the use of the app that maybe someone can answer, as well as some bluetooth connection issues.

I'm running the app on an Amazon Fire HD 8, which is a reasonably specced device, it seems to have no problem keeping up with the 350fps I'm seeing with virtual cockpit and a couple of other screens I don't want disabled.

However at random any time between a few minutes and maybe 20 minutes the fps drops to 0, the app is still responsive, and it seems like the bluetooth adaptor has "lost" pairing with the tablet. I say lost pairing rather than just lost the connection because the android notification bar starts beeping and if I scroll it down showing "Pairing request, Touch to Pair with OBDLink LX" even though it might have just been paired a few minutes earlier, and despite me NOT pressing the pairing button on the adaptor. This message only appears briefly then disappears, returning a few seconds later, in an infinite loop.

If I tap on it it takes me to the pairing screen with the pin number but if I don't hit pair very quickly I get another message saying "Couldn't pair with OBDLink LX because of an incorrect PIN or passkey". If I do quickly hit pair sometimes it pairs, sometimes it says "Can't communicate with OBDLink LX".

Typically when this happens I can no longer see or pair to the device at all, pressing the pairing button for 2 seconds doesn't work (blue light keeps flashing slowly instead of speeding up as in pairing mode) and a 20 second press for a full reset doesn't work either. The only thing that works is to unplug it from the car, forget the pairing on the tablet, press the button and pair from scratch, and then it will work for another 5-20 minutes if I'm lucky.

Anyone had this issue with this adaptor ? It seems to be a bug with the adaptor itself as far as I can see, as if the adaptor is crashing and rebooting and losing the pairing after a while. Not good for an expensive, recommended adaptor! :?

I tried to do a firmware update on the adaptor - the windows version of the updater just crashes for me (yay!) and I had a lot of difficulty with the OBDLink android app as well, but finally got it to a point where it detected the device and offered a firmware update version 4.3.0 which I have now installed. Strangely - the firmware version reported on the device before the firmware upgrade was 0.0.0 ! After the firmware update it does report 4.3.0.

Since the firmware update I have not driven the car so I don't know if the dropouts are fixed yet but I notice the behaviour of the adaptor is different now. Previously when exiting Canion the red can bus data light would also stop when bluetooth disconnected (bluetooth light going from solid back to flashing) however on the new firmware even after the bluetooth connection is disconnected the red can bus data light keeps flashing until the car is turned off... hopefully this will not prevent sleep mode working...

If I still have problems with the adaptor I'll contact scantool via their forum for some help but thought I'd check here first if anyone has seen and fixed the same issue.

Regarding Canion itself I have a few questions.

1) The Odo figure (in miles) seems to be a bit out - the car has done just over 41k miles, but the odo figure is out from the dashboard figure by around 40 miles. I assume this is a rounding error in converting from km ? All other figures seem to be exact so this seems strange.

2) I have miles/kWh enabled for consumption, on the "my trip timer" screen miles/kWh line it has heater and summary, can someone explain to me how these figure relate, as its hard to get my head around miles/kWh for heater consumption as it is a backwards unit for this purpose ?

For example when it says heater 2.0, summary 4.0, what I think this means is that my total miles/kWh consumption inclusive of heater usage (EG how far I will really be able to drive) is 4 mile/kWh, and that the heater has consumed 2 miles/kWh of potential range - in other words if I add the two figures together to get 6kWh, this would be the miles/kWh that I would be achieving if the heater had been turned off and the battery was only propelling the car ?

Also on this line, I find if both the heater and AC is turned on at the same time, there is not enough room for all three figures on the line - the labels overwrite the numbers. I tried reducing the font size but the font size setting does not appear to influence the text on the my trip timer page. The tablet has a 1280 x 800 screen resolution so this should be plenty.

3) I tried to use Auto ScreenCapture Interval to capture screenshots of charging every 5 minutes but it did not appear to work. I set it to 300, exited the program cleanly to ensure it saved the preference, launched again, checked it was still set to 300, put it on the battery voltage graph, started charging the car, but no screenshots were saved. Is there anything else that needs to be done for this to work ?

4) When not connected, some screens like "my trip timer" have snapshots (?) accessed by the top right menu with a date and time on it. It's unclear to me whether these are automatically created at the end of each session, and thus whether they represent trip data at the end of a session ? Is it possible to have a "trip" span multiple power on cycles of the car ?

On my daily commute I stop part way in each direction and turn the car off for 15 minutes, it doesn't seem like there is any way to combine these two driving sessions into one "trip" for the purposes of averaging miles/kWh across the entire trip ?

The battery status graphs also seem to have the same date/time selector - is this also just a single snapshot at the end of a session ? Is there a way to manually create additional snapshots in the battery status graph during a driving session that will be saved and be accessible via the date/time selector ?

5) I've seen some crazy high figures in the Trip history graph page where there will be one outlier that says something ridiculous like 115 miles/kWh when all the rest are around 5.... I think this may be caused by sitting stationary in traffic for a while as each bar starts off high and creeps downwards ?

I've only been using the app for a day yet, and with an uncooperative OBDLink adaptor holding me back somewhat so I'm sure I'll learn more about it as I get used to it. :)

Re: Canion

Posted: Tue Apr 17, 2018 1:47 pm
by DBMandrake
I've had a chance to drive home and do some testing with the latest 4.3.0 firmware on the OBDLink LX but unfortunately it doesn't solve the problems and in fact seems to introduce one new problem! :(

The new problem is that with the original firmware (version unknown as the OBDLink app reported it as 0.0.0) when I exited Canion and the bluetooth connection was closed the red can bus light would stop flashing, implying that the filtered "monitor mode" was automatically stopped.

This does not seem to happen on the 4.3.0 firmware. When I exit Canion the red can bus light continues to flash so long as there is activity on the bus, (key on, charging, doors opened or closed etc) which to me suggests that monitor mode is not being disabled when the bluetooth connection was closed.

I tested to see if power saving mode is working after closing Canion and unfortunately it is not - I turned the android tablet off completely, left the car for an 8 hour work day, when I came back and looked through the window (without unlocking doors, tablet still turned off etc) the power light was still solid green rather than the flashing green as it should be if the adaptor was in power save mode.

Furthermore as soon as I turned on the key the red can bus light started flashing again indicating that after being left for 8 hours the adaptor was still in monitor mode, which probably explains why power saving mode hadn't kicked in.

Shouldn't Canion be disabling monitor mode and resetting the adaptor to default settings on exit ? Perhaps older OBDLink firmware automatically disabled monitor mode when the bluetooth connection was closed and the latest firmware doesn't ? Not sure if this is a firmware bug in the adaptor, a deliberate change in behaviour in new firmware, or a bug in Canion not resetting the adaptor on exit but it can hopefully be addressed.

Regarding the intermittent connection drops, I've identified two separate issues going on. One is that something is causing the bluetooth pairing between the tablet and adaptor to be "lost" after a while, seemingly at random. Once this happens one device (I'm not sure if its the tablet or the adaptor) is trying to automatically reconnect but because the pairing PIN number is a different random number every time you try to pair (something I have not seen on other bluetooth adaptors before) the saved PIN number on the tablet no longer matches so it refuses to pair automatically, instead prompting the user to confirm the new pin number.

And because it keeps retrying every few seconds, with a different PIN number on every attempt (!) its quite hard to re-pair because if you are not very quick to acknowledge the prompt it fails with a wrong PIN number error. This changing of the pairing PIN on every attempt is very problematic.

The second problem I've identified is the adaptor is sometimes locking up completely. When this happens the bluetooth connection is lost, the bluetooth device is no longer visible to the tablet at all, a 2 second press of the button does not put it into pairing mode, AND a 20 second press of the button which is a "factory reset" which normally causes the power light to flash and the adaptor to reboot does NOT work either. It just sits with a solid power light and slowly flashing bluetooth light but is otherwise completely unresponsive to the button or connection attempts from the tablet.

The only thing that gets it working again after this is a hard reboot by unplugging it, and after that it's necessary to start the pairing process from scratch.

Both the loss of pairing and ever changing PIN number, and the apparent hard lockup would seem to be problems that only a firmware update could fix so I guess I need to open a support thread on the scantool website to see what they have to say about it. Pretty disappointing how unreliable this adaptor is considering the cost of it and that it's a recommended adaptor for both Canion and EVbatmon. :(

If there's anything I can do to help troubleshoot and narrow down these issues to get this adaptor working reliably I'd be glad to help - I have experience with debugging and troubleshooting, so given a few pointers in the right direction I may be able to help.

Re: Canion

Posted: Wed Apr 18, 2018 8:32 am
by DBMandrake
I've posted in this thread over in the scantool forum, should be interesting! :twisted: ... 8#msg52688

The post I'm replying to (responding to someone else with the same problem) seems to be trying to say that the automatic reconnection that Canion performs after 10 seconds of no monitor data is the cause of the problem but I don't believe this is the case at all.

Perhaps one of the Canion authors could have a look at my post on the scantool thread and see if the logic of my troubleshooting is correct ? I think I will be able to reproduce the problems with loss of pairing or the adaptor locking up even if I connect with a bluetooth serial program and initialise the adaptor with the same AT/ST commands as Canion to put it into monitor mode. I think it is firmware bug(s) in the adaptor that may only be apparent when used in monitor mode.

Is an exact list of the initialization commands used by Canion on start and exit available to assist my diagnosis of the issue ?

Re: Canion

Posted: Thu Apr 19, 2018 8:36 am
by Zelenec
Did you try to unpair all other BT devices? Turn the WiFi off, uncheck all but necessary panels in Canion settings. I had all described issues. They dissapeared when the MX was the only paired BT device and the WiFi was off. It's interesting that I never noticed such problems using AH design OBD reader.