Page 2 of 7

Re: Hi everyone....have two 2012 I-Mievs.....need help....

Posted: Thu Oct 01, 2020 4:46 pm
by jray3
If you do need to replace the MCUY, I have a spare 2012.....

Re: Hi everyone....have two 2012 I-Mievs.....need help....

Posted: Thu Oct 01, 2020 5:02 pm
by dweaver
Thanks kiev,

I ran it through the gears, looks fine on the dash through all of the letters. Everything still the same, won't start....same battery light and high voltage light.

Interesting though, after I had it towed back home from the dealer a few days ago, I had noticed after popping the hood, the plastic nut was missing off the battery plastic cover. I called the dealer, he spoke to the tech. The tech said he never had the front hood open, never had to open it, and never touched the 12V battery. Really?
So, after you asked me previously about checking the 12V charge, I found the plastic nut on the cowl under the front windshield....just laying there. Someone had it off.

Also, the dealer informed me a few days ago with estimate that engineers at Mitsubishi Motors told the tech by phone, since a code didn't set, that it was the ac to dc inverter. Really?
Does any of this sound right?
Also, isn't the ac to dc inverter in the OBC? Which is covered under the extended warranty?

Anyway, it's raining right now. First thing tomorrow in daylight I'll check the static 12V battery reading in Raspberry for comparison. Then charge the Silver 12V battery up and then see what happens.

Thanks again for the time and help.

Thanks jray....

Posted: Thu Oct 01, 2020 5:05 pm
by dweaver
I appreciate that offer.

I'll keep updating the situation.


Re: Hi everyone....have two 2012 I-Mievs.....need help....

Posted: Thu Oct 01, 2020 6:30 pm
by kiev
Sounds like some basic electrical troubleshooting is needed, such as checking all the fuses and relays related to the Starting circuit and the EV-ECU, which is the master control unit for the MCU, OBC, BMU, the Pack, etc. If fuse #7 or #11 is blown then that keeps many systems off.

Also there are some fusible links on the aux battery positive terminal; a blown link would be a no-start issue, and maybe somebody was looking around in there to check those links?

If the dash lights up with the key at ON, but nothing happens when starting...i'm thinking there is no 12V power getting to something in the starting circuits. The MCU is referred to as an Inverter, for example in this circuit diagram: ... dex_M1.htm

No luck....charged 12V to 13.3....

Posted: Fri Oct 02, 2020 12:03 pm
by dweaver
it was reading 12.35 before charging....didn't matter. Checked fuses all over. No luck. I guess it's all worth checking before spending a bunch of money.
Maybe the MCU is the right call.
I would try a used one....but not putting $4000 into this for a new one. I don't have the equipment either to put my VIN in an MCU.
I agree kiev.....there might be no 12V getting to the starting circuits for some reason.
And, car won't charge main battery system either when hooked up. No start up sounds of cooling fluid pump or anything.
Car shows there is a 68 mile charge in the system.
Not sure what else to try except a used MCU.
Thanks for the help.

Re: Hi everyone....have two 2012 I-Mievs.....need help....

Posted: Fri Oct 02, 2020 3:01 pm
by kiev
Howdy Dale,

That was just their guess about needing an MCU. Without some real DTC codes it was just a guess based upon. nothing.

My guesses are based upon many hours tracing circuits and troubleshooting failed OBCs, DCDC and MCUs.

It is likely that the EV-ECU is not getting 12V power, which would cause the car to not go to READY, and would cause no DTC codes to show up. If the HV warning light shows up on the dash (Car with !), then there is definitely a DTC to indicate what is wrong with the car. Even if the MCU were failed, there should still be 12V power getting to the rest of the system to display the codes--that is why i posted the link to the wiring diagram.

i can post more wiring diagrams of stuff to check if you are up to it. If you have given up then let me know.


Hello....I probably should mention a few more things.....

Posted: Fri Oct 02, 2020 3:25 pm
by dweaver
I tried the Innova Car Scan couldn't communicate. The guys at Autozone were puzzled.

I can try another code reader....which one will work with this car?

This all began after my wife returned from a grocery store. Stopped, parked, and shut it off. Went to go again and nothing.

And.....I forgot. Over the last week while trying to start it.....the brake light will come on. WTH? Why would that happen?

Thanks for any input.

I can check some things. I'm not real good with electronics and don't have good electronic testing equipment. I'm 62. :lol:

Should I get the Icarsoft?

Posted: Fri Oct 02, 2020 4:17 pm
by dweaver
My problem sounds identical to this guys....

"I-miev does not start. Need help" from Jan. 20th 2019.

So....he cleared the codes and it fixed everything?

Re: Hi everyone....have two 2012 I-Mievs.....need help....

Posted: Fri Oct 02, 2020 9:49 pm
by jray3
Dale, I recommend the iCarsoft i909 as a fine scan tool that can read and clear the codes from an i-MiEV. It costs $104 on Amazon. The tool is simple, but since it only has 6 buttons, is a bit slow and clunky to use (CaniOn is much better for individual cell voltages and temperature readings)- and the menus are somewhat awkward Japenglish... Keep plugging away and you'll solve the issues. When I was able to diagnose and fix the failed onboard charger for under $500 while dealers were demanding $4200, you can bet that was good for some spousal currency! :P

Re: Hi everyone....have two 2012 I-Mievs.....need help....

Posted: Sat Oct 03, 2020 5:02 am
by dweaver
Thank you all. I ordered the icarsoft i909. Might have it by Thursday. I would probably end up needing it for Raspberry anyway in the future.

Is it possible that the dealer is just incompetent, considering they only sold maybe 4 of these cars since 2012? :lol: We live in commuter town to D.C.. The Chevy dealer here won't even carry and sell a Bolt. They are so backward.

I would try checking the 12V battery under load, but it's new, dated 1/18 and has full charge, and it appears there is no draw on it anyway when I try to go to ready. I'm not ignoring your ideas and suggestions kiev, I really appreciate them, just based on my experiences with 12V batteries, it's not that. I could just switch 12V batteries from Raspberry to Silver and see what happens. At this point, I'll just wait for the i909 and see what happens then.